[ltp] 2.6.19-rc <-> ThinkPads, summary

Martin Lorenz linux-thinkpad@linux-thinkpad.org
Tue, 7 Nov 2006 12:45:51 +0100

On Mon, Nov 06, 2006 at 11:23:30PM +0100, b42 wrote:
> On Sat, 4 Nov 2006 04:49:07 +0100
> Adrian Bunk <bunk@stusta.de> wrote:
>  ...
> > - ThinkPad X60: lose ACPI events after suspend/resume
> >                 not every time, but roughly 3 out of 4 times
> > - question: Does reverting commit
> > cf4c6a2f27f5db810b69dcb1da7f194489e8ff88 ("i386: Factor out common io
> > apic routing entry access") in -rc4 help?
> > - question: If yes, did the post -rc4 arch/i386/kernel/io_apic.c
> > changes fix it?
>  ...
> I tried 2.6.19-rc4 on R60 today and had the same problem - after resume
> acpid wasn't able to see any ACPI events. Unfortunately i didn't figure
> out how to revert the commit, but with 2.6.19-rc4-git11 it seems to be
> OK again.

just tried the latest git from this morning
$ cg-status
    >master     64cb104e9d52f60cc18b9ed0d17edb34110a46b2
     origin     64cb104e9d52f60cc18b9ed0d17edb34110a46b2

now I don't get my screen back after suspend

when trying to switch vt i see the backlicght flicker, but no chance to get

this worked well with the latest rc I tried before (rc3-git???)

so I cant't say anything about ACPI because I have to reboot after suspend.
the system is ok, I can blindly hit the "shutdown now" button in the 
bottom-right corner of my screen and it does come down nicely.

Dipl.-Ing. Martin Lorenz

            They that can give up essential liberty 
	    to obtain a little temporary safety 
	    deserve neither liberty nor safety.
                                   Benjamin Franklin

please encrypt your mail to me
GnuPG key-ID: F1AAD37D
get it here:

ICQ UIN: 33588107